What is the best practice way to write ternary inside ternary like in my example code?I want to make the code more readable and correct and I want to know the correct way to write it.
<TouchableOpacity style={ darkMode ? filterState === 'A' ? styles.activeButtonDark : styles.buttonDark : filterState === 'A' ? styles.activeButton : styles.button }></TouchableOpacity><TouchableOpacity style={ darkMode ? filterState === 'B' ? styles.activeButtonDark : styles.buttonDark : filterState === 'B' ? styles.activeButton : styles.button }></TouchableOpacity>